import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\buser\\s+\\S+\\s+pswd\\s+(\\d+)";
final String string = "user stuff here 5\n"
+ "user banana1 pswd 4 \n"
+ "user lemon2 pswd 5\n"
+ "mumbo jumbo 12333 3\n"
+ "user h3lp pswd 8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}