using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\buser\s+\S+\s+pswd\s+(\d+)";
string input = @"user stuff here 5
user banana1 pswd 4
user lemon2 pswd 5
mumbo jumbo 12333 3
user h3lp pswd 8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}