package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\buser\s+\S+\s+pswd\s+(\d+)`)
var str = `user stuff here 5
user banana1 pswd 4
user lemon2 pswd 5
mumbo jumbo 12333 3
user h3lp pswd 8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}