using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.).* - (?:(\d+)mm - )?.*\(([\d\.]+)\"" x ([\d\.]+)\""\)";
string input = @"N251 - 8mm - 4' x 10' (49.21"" x 122.05"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}