re = /^(.).* - (?:(\d+)mm - )?.*\(([\d\.]+)\" x ([\d\.]+)\"\)/
str = 'N251 - 8mm - 4\' x 10\' (49.21" x 122.05")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end