package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.).* - (?:(\d+)mm - )?.*\(([\d\.]+)\" x ([\d\.]+)\"\)`)
var str = `N251 - 8mm - 4' x 10' (49.21" x 122.05")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}