// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(.).* - (?:(\d+)mm - )?.*\(([\d\.]+)\" x ([\d\.]+)\"\)"#).unwrap();
let string = "N251 - 8mm - 4' x 10' (49.21\" x 122.05\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}