const regex = new RegExp('^(.).* - (?:(\\d+)mm - )?.*\\(([\\d\\.]+)\\" x ([\\d\\.]+)\\"\\)', 'g')
const str = `N251 - 8mm - 4' x 10' (49.21" x 122.05")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}