#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.{16})(?=.*?\S{3})(?>[A-Za-z][a-z]* ?\b){1,3}$"
Local $sString = "Should match:" & @CRLF & _
"" & @CRLF & _
"Yaw" & @CRLF & _
"yaw" & @CRLF & _
"James Bond" & @CRLF & _
"Monkey D Luffy" & @CRLF & _
"List item" & @CRLF & _
"" & @CRLF & _
"Shouldn't match:" & @CRLF & _
"" & @CRLF & _
"YaW" & @CRLF & _
"Two spaces" & @CRLF & _
"No no no" & @CRLF & _
"JamesBond"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")