const regex = /^(?!.{16})(?=.*?\S{3})(?>[A-Za-z][a-z]* ?\b){1,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.{16})(?=.*?\\S{3})(?>[A-Za-z][a-z]* ?\\b){1,3}$', 'gm')
const str = `Should match:
Yaw
yaw
James Bond
Monkey D Luffy
List item
Shouldn't match:
YaW
Two spaces
No no no
JamesBond`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}