re = /^(?!.{16})(?=.*?\S{3})(?>[A-Za-z][a-z]* ?\b){1,3}$/m
str = 'Should match:
Yaw
yaw
James Bond
Monkey D Luffy
List item
Shouldn\'t match:
YaW
Two spaces
No no no
JamesBond'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end