import re
regex = re.compile(r"^(?!.{16})(?=.*?\S{3})(?>[A-Za-z][a-z]* ?\b){1,3}$", flags=re.MULTILINE)
test_str = ("Should match:\n\n"
"Yaw\n"
"yaw\n"
"James Bond\n"
"Monkey D Luffy\n"
"List item\n\n"
"Shouldn't match:\n\n"
"YaW\n"
"Two spaces\n"
"No no no\n"
"JamesBond")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")