using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(.*?@\s*\d+)\s*(.*?&.*)";
string substitution = @"$1#$2";
string input = @"moon @ 215466
sun & stars world
the sea 345454
sky @ 464654";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}