import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(.*?@\\s*\\d+)\\s*(.*?&.*)";
final String string = "moon @ 215466 \n"
+ "sun & stars world\n\n"
+ "the sea 345454 \n"
+ "sky @ 464654";
final String subst = "$1#$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}