re = /(?m)(.*?@\s*\d+)\s*(.*?&.*)/m
str = 'moon @ 215466
sun & stars world
the sea 345454
sky @ 464654'
subst = '$1#$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result