use strict;
my $str = 'moon @ 215466
sun & stars world
the sea 345454
sky @ 464654';
my $regex = qr/(?m)(.*?@\s*\d+)\s*(.*?&.*)/mp;
my $subst = '$1#$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";