using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\b|(?<=\W)(?=\W))\S+?(?=$|\b|(?<=\W)(?=\W))";
string input = @"#include <stdio.h>
int main()
{
printf(""Hello, World!"");
return 0;
}
public class HelloWorld {
public static void main(String[] args) {
System.out.println(""Hello, World!"");
}
}
MsgBox, Hello, World!";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}