import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\b|(?<=\\W)(?=\\W))\\S+?(?=$|\\b|(?<=\\W)(?=\\W))";
final String string = "#include <stdio.h>\n"
+ "int main()\n"
+ "{\n"
+ " printf(\"Hello, World!\");\n"
+ " return 0;\n"
+ "}\n\n\n\n"
+ "public class HelloWorld {\n"
+ " public static void main(String[] args) {\n"
+ " System.out.println(\"Hello, World!\");\n"
+ " }\n\n"
+ "}\n\n\n\n"
+ "MsgBox, Hello, World!";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}