import re
regex = re.compile(r"(?<=^|\b|(?<=\W)(?=\W))\S+?(?=$|\b|(?<=\W)(?=\W))", flags=re.DOTALL)
test_str = ("#include <stdio.h>\n"
"int main()\n"
"{\n"
" printf(\"Hello, World!\");\n"
" return 0;\n"
"}\n\n\n\n"
"public class HelloWorld {\n"
" public static void main(String[] args) {\n"
" System.out.println(\"Hello, World!\");\n"
" }\n\n"
"}\n\n\n\n"
"MsgBox, Hello, World!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")