re = /(?<=^|\b|(?<=\W)(?=\W))\S+?(?=$|\b|(?<=\W)(?=\W))/
str = '#include <stdio.h>
int main()
{
printf("Hello, World!");
return 0;
}
public class HelloWorld {
public static void main(String[] args) {
System.out.println("Hello, World!");
}
}
MsgBox, Hello, World!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end