const regex = new RegExp('\\"code', 'gm')
const str = `more text "some testhere "code="M" this is a test`;
const subst = `" code`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);