import Foundation
let pattern = #"\"code"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"more text "some testhere "code="M" this is a test"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"" code"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)