re = /\"code/m
str = 'more text "some testhere "code="M" this is a test'
subst = '" code'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result