$re = '/\"code/m';
$str = 'more text "some testhere "code="M" this is a test';
$subst = "\" code";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;