import re
regex = re.compile(r"\"code", flags=re.MULTILINE)
test_str = "more text \"some testhere \"code=\"M\" this is a test"
subst = "\" code"
result = regex.sub(subst, test_str)
if result:
print(result)