using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:gpa[ :]+)(\d\.?\d{0,2})(?:[/\d\. ]{0,6})?)|((\d\.?\d{0,2})(?:[/\d\. ]{0,6})? ?(?:gpa))";
string input = @"GPA 3.75/4.00
GPA 3.75/4.0
GPA 3.75 /4.0
GPA 3.75 / 4.0
GPA 3.7 / 4 aaa
Major GPA: 3.6/4.0
GPA 3.1
GPA 3
some text GPA 3
3.25/4.0 GPA
some text 3.26 / 4.0 GPA
Minor in Art and Technology - 3.5/4.0 GPA aaaa
Minor in Art and Technology - 3.5 / 4.3 GPA aaaa
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}