import Foundation
let pattern = #"((?:gpa[ :]+)(\d\.?\d{0,2})(?:[/\d\. ]{0,6})?)|((\d\.?\d{0,2})(?:[/\d\. ]{0,6})? ?(?:gpa))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
GPA 3.75/4.00
GPA 3.75/4.0
GPA 3.75 /4.0
GPA 3.75 / 4.0
GPA 3.7 / 4 aaa
Major GPA: 3.6/4.0
GPA 3.1
GPA 3
some text GPA 3
3.25/4.0 GPA
some text 3.26 / 4.0 GPA
Minor in Art and Technology - 3.5/4.0 GPA aaaa
Minor in Art and Technology - 3.5 / 4.3 GPA aaaa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)