re = /((?:gpa[ :]+)(\d\.?\d{0,2})(?:[\/\d\. ]{0,6})?)|((\d\.?\d{0,2})(?:[\/\d\. ]{0,6})? ?(?:gpa))/mi
str = 'GPA 3.75/4.00
GPA 3.75/4.0
GPA 3.75 /4.0
GPA 3.75 / 4.0
GPA 3.7 / 4 aaa
Major GPA: 3.6/4.0
GPA 3.1
GPA 3
some text GPA 3
3.25/4.0 GPA
some text 3.26 / 4.0 GPA
Minor in Art and Technology - 3.5/4.0 GPA aaaa
Minor in Art and Technology - 3.5 / 4.3 GPA aaaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end