import re
regex = re.compile(r"((?:gpa[ :]+)(\d\.?\d{0,2})(?:[/\d\. ]{0,6})?)|((\d\.?\d{0,2})(?:[/\d\. ]{0,6})? ?(?:gpa))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("GPA 3.75/4.00\n"
"GPA 3.75/4.0\n"
"GPA 3.75 /4.0\n"
"GPA 3.75 / 4.0\n"
"GPA 3.7 / 4 aaa\n"
"Major GPA: 3.6/4.0\n"
"GPA 3.1\n"
"GPA 3\n"
"some text GPA 3\n"
"3.25/4.0 GPA\n"
"some text 3.26 / 4.0 GPA\n"
"Minor in Art and Technology - 3.5/4.0 GPA aaaa\n"
"Minor in Art and Technology - 3.5 / 4.3 GPA aaaa\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")