const regex = new RegExp('((?:gpa[ :]+)(\\d\\.?\\d{0,2})(?:[/\\d\\. ]{0,6})?)|((\\d\\.?\\d{0,2})(?:[/\\d\\. ]{0,6})? ?(?:gpa))', 'gmi')
const str = `GPA 3.75/4.00
GPA 3.75/4.0
GPA 3.75 /4.0
GPA 3.75 / 4.0
GPA 3.7 / 4 aaa
Major GPA: 3.6/4.0
GPA 3.1
GPA 3
some text GPA 3
3.25/4.0 GPA
some text 3.26 / 4.0 GPA
Minor in Art and Technology - 3.5/4.0 GPA aaaa
Minor in Art and Technology - 3.5 / 4.3 GPA aaaa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}