import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+\\b";
final String string = "http://www.66play.com/Home/share/match/id/39455 \n"
+ "http://www.66play.com/match-detail-151951\n"
+ "http://www.66play.com/Home/share/match/id/148853?referral=a0ed8f500e2a12da";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}