import Foundation
let pattern = #"\b\d+\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://www.66play.com/Home/share/match/id/39455
http://www.66play.com/match-detail-151951
http://www.66play.com/Home/share/match/id/148853?referral=a0ed8f500e2a12da
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)