const regex = /\b\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\b', 'g')
const str = `http://www.66play.com/Home/share/match/id/39455
http://www.66play.com/match-detail-151951
http://www.66play.com/Home/share/match/id/148853?referral=a0ed8f500e2a12da`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}