re = /\b\d+\b/
str = 'http://www.66play.com/Home/share/match/id/39455
http://www.66play.com/match-detail-151951
http://www.66play.com/Home/share/match/id/148853?referral=a0ed8f500e2a12da'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end