#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.)\1{2,}"
Local $sString = "teeeexxxxt" & @CRLF & _
"this is a texxt" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaa"
Local $sSubst = "\1\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)