import Foundation
let pattern = #"(.)\1{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
teeeexxxxt
this is a texxt
aaaaaaaaaaaaaaaaaaaaaaaaaaaaa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)