use strict;
my $str = 'teeeexxxxt
this is a texxt
aaaaaaaaaaaaaaaaaaaaaaaaaaaaa';
my $regex = qr/(.)\1{2,}/mp;
my $subst = '\\1\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";