re = /(.)\1{2,}/m
str = 'teeeexxxxt
this is a texxt
aaaaaaaaaaaaaaaaaaaaaaaaaaaaa'
subst = '\\1\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result