$re = '/(.)\1{2,}/m';
$str = 'teeeexxxxt
this is a texxt
aaaaaaaaaaaaaaaaaaaaaaaaaaaaa';
$subst = "\1\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;