const regex = /(?<=[\(\{\['"]).+(?=[\)\}\]'"])/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\(\\{\\[\'"]).+(?=[\\)\\}\\]\'"])', 'gu')
const str = `[ <>?!@#\$%^&*()_+]
[as897456231YUIKJNHB]
qaedsfgvbn!@#\$%5678i9ojnbVBNm[ dtrfyg uigfjhcgvn]
( <>?!@#\$%^&*()_+)
(as897456231YUIKJNHB)
qaedsfgvbn!@#\$%5678i9ojnbVBNm( dtrfyg uigfjhcgvn)
{ <>?!@#\$%^&*()_+}
{as897456231YUIKJNHB}
qaedsfgvbn!@#\$%5678i9ojnbVBNm{ dtrfyg uigfjhcgvn}
'2qw4s3detrfRFAGDS%^&'
" 87546132"
23456ftigkhRTGSDF56t'2qw4s3detrfRFAGDS%^&'
oijhkOIKJN8" 87546132"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}