$re = '/(?<=[\(\{\[\'"]).+(?=[\)\}\]\'"])/u';
$str = '[ <>?!@#$%^&*()_+]
[as897456231YUIKJNHB]
qaedsfgvbn!@#$%5678i9ojnbVBNm[ dtrfyg uigfjhcgvn]
( <>?!@#$%^&*()_+)
(as897456231YUIKJNHB)
qaedsfgvbn!@#$%5678i9ojnbVBNm( dtrfyg uigfjhcgvn)
{ <>?!@#$%^&*()_+}
{as897456231YUIKJNHB}
qaedsfgvbn!@#$%5678i9ojnbVBNm{ dtrfyg uigfjhcgvn}
\'2qw4s3detrfRFAGDS%^&\'
" 87546132"
23456ftigkhRTGSDF56t\'2qw4s3detrfRFAGDS%^&\'
oijhkOIKJN8" 87546132"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);