import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?<=[\(\{\['"]).+(?=[\)\}\]'"])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
[ <>?!@#$%^&*()_+]
[as897456231YUIKJNHB]
qaedsfgvbn!@#$%5678i9ojnbVBNm[ dtrfyg uigfjhcgvn]
( <>?!@#$%^&*()_+)
(as897456231YUIKJNHB)
qaedsfgvbn!@#$%5678i9ojnbVBNm( dtrfyg uigfjhcgvn)
{ <>?!@#$%^&*()_+}
{as897456231YUIKJNHB}
qaedsfgvbn!@#$%5678i9ojnbVBNm{ dtrfyg uigfjhcgvn}
'2qw4s3detrfRFAGDS%^&'
" 87546132"
23456ftigkhRTGSDF56t'2qw4s3detrfRFAGDS%^&'
oijhkOIKJN8" 87546132"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)