# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[\(\{\['\"]).+(?=[\)\}\]'\"])"
test_str = ("[ <>?!@#$%^&*()_+]\n"
"[as897456231YUIKJNHB]\n"
"qaedsfgvbn!@#$%5678i9ojnbVBNm[ dtrfyg uigfjhcgvn]\n\n"
"( <>?!@#$%^&*()_+)\n"
"(as897456231YUIKJNHB)\n"
"qaedsfgvbn!@#$%5678i9ojnbVBNm( dtrfyg uigfjhcgvn)\n\n"
"{ <>?!@#$%^&*()_+}\n"
"{as897456231YUIKJNHB}\n"
"qaedsfgvbn!@#$%5678i9ojnbVBNm{ dtrfyg uigfjhcgvn}\n\n"
"'2qw4s3detrfRFAGDS%^&'\n"
"\" 87546132\"\n"
"23456ftigkhRTGSDF56t'2qw4s3detrfRFAGDS%^&'\n"
"oijhkOIKJN8\" 87546132\"")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.