re = /(?<=[\(\{\['"]).+(?=[\)\}\]'"])/
str = '[ <>?!@#$%^&*()_+]
[as897456231YUIKJNHB]
qaedsfgvbn!@#$%5678i9ojnbVBNm[ dtrfyg uigfjhcgvn]
( <>?!@#$%^&*()_+)
(as897456231YUIKJNHB)
qaedsfgvbn!@#$%5678i9ojnbVBNm( dtrfyg uigfjhcgvn)
{ <>?!@#$%^&*()_+}
{as897456231YUIKJNHB}
qaedsfgvbn!@#$%5678i9ojnbVBNm{ dtrfyg uigfjhcgvn}
\'2qw4s3detrfRFAGDS%^&\'
" 87546132"
23456ftigkhRTGSDF56t\'2qw4s3detrfRFAGDS%^&\'
oijhkOIKJN8" 87546132"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end