# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:\K.+://g;t' <<< "gejoxloq@gmail.com:DefeatedHarlequinSalamander:79c0d5007090af1832e9f3995b01513e:OTM4NTI5MzExNzOdjnDk2.YfrnuQ.KCDRHpx1E-YDSway-76SfkwivnQ"