re = /:\K.+:/
str = 'gejoxloq@gmail.com:DefeatedHarlequinSalamander:79c0d5007090af1832e9f3995b01513e:OTM4NTI5MzExNzOdjnDk2.YfrnuQ.KCDRHpx1E-YDSway-76SfkwivnQ'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result