const regex = /:\K.+:/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\K.+:', 'g')
const str = `gejoxloq@gmail.com:DefeatedHarlequinSalamander:79c0d5007090af1832e9f3995b01513e:OTM4NTI5MzExNzOdjnDk2.YfrnuQ.KCDRHpx1E-YDSway-76SfkwivnQ`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);