$re = '/^([01]?\d|2[0-3]):([0-5][0-9])/m';
$str = '12:45am
9:59 AM
6:60am
15:00
90:45
12:45
2:00
five o\'clock
[0-2]?\\d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);