// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([01]?\d|2[0-3]):([0-5][0-9])").unwrap();
let string = "12:45am
9:59 AM
6:60am
15:00
90:45
12:45
2:00
five o'clock
[0-2]?\\d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}