import re
regex = re.compile(r"^([01]?\d|2[0-3]):([0-5][0-9])", flags=re.MULTILINE)
test_str = ("12:45am\n"
"9:59 AM\n"
"6:60am\n"
"15:00\n"
"90:45\n"
"12:45\n"
"2:00\n"
"five o'clock\n\n"
"[0-2]?\\d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")